同花顺建仓买卖指标公式

m:=21;

n:=21;

DC:=INDEXC;

DC1:=3;

DV:=INDEXC;

var11:=ZIG(DC1,6)>REF(ZIG(DC1,6),1) AND REF(ZIG(DC1,6),1)<=REF(ZIG(DC1,6),2) AND REF(ZIG(DC1,6),2)<=REF(ZIG(DC1,6),3);

var12:=ZIG(DC1,6)<REF(ZIG(DC1,6),1) AND REF(ZIG(DC1,6),1)>=REF(ZIG(DC1,6),2) AND REF(ZIG(DC1,6),2)>=REF(ZIG(DC1,6),3);

var13:=ZIG(DC1,22)>REF(ZIG(DC1,22),1) AND REF(ZIG(DC1,22),1)<=REF(ZIG(DC1,22),2) AND REF(ZIG(DC1,22),2)<=REF(ZIG(DC1,22),3);

var14:=ZIG(DC1,22)<REF(ZIG(DC1,22),1) AND REF(ZIG(DC1,22),1)>=REF(ZIG(DC1,22),2) AND REF(ZIG(DC1,22),2)>=REF(ZIG(DC1,22),3);

var15:=ZIG(DC1,51)>REF(ZIG(DC1,51),1) AND REF(ZIG(DC1,51),1)<=REF(ZIG(DC1,51),2) AND REF(ZIG(DC1,51),2)<=REF(ZIG(DC1,51),3);

var16:=ZIG(DC1,51)<REF(ZIG(DC1,51),1) AND REF(ZIG(DC1,51),1)>=REF(ZIG(DC1,51),2) AND REF(ZIG(DC1,51),2)>=REF(ZIG(DC1,51),3);

var17:=ZIG(DC1,72)>REF(ZIG(DC1,72),1) AND REF(ZIG(DC1,72),1)<=REF(ZIG(DC1,72),2) AND REF(ZIG(DC1,72),2)<=REF(ZIG(DC1,72),3);

var18:=ZIG(DC1,72)<REF(ZIG(DC1,72),1) AND REF(ZIG(DC1,72),1)>=REF(ZIG(DC1,72),2) AND REF(ZIG(DC1,72),2)>=REF(ZIG(DC1,72),3);

买:=(var11+var13+var15+var17);

卖:=(var12+var14+var16+var18);

新价:DC,colorwhite;//

DRAWTEXT(买>0,DC*0.99,’必进’),colorred,;

DRAWTEXT(卖>0,DC*1.02,’清仓’),colorgreen,;

b:=TROUGHBARS(DC1,5,1)=0;

e:=PEAKBARS(DC1,5,1)=0;

DRAWICON(b,INDEXL,1),colorred;

DRAWICON(e,INDEXH,2);

DRAWNUMBER(e,INDEXC*0.98,TOSTRING(INDEXH,2));//画数字

DRAWNUMBER(b,INDEXC*0.98,TOSTRING(INDEXL,2));//画数字

突破:REF(EMA(DC,14),1),coloryellow;//

A1X:=(EMA(DC,10)-突破)/突破*100;

多方:=IF(A1X>=0,REF(EMA(DC,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);

空方:=IF(A1X<0,REF(EMA(DC,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);

STICKLINE(A1X>=0,多方,突破,0,0),COLOR000099;//柱线

STICKLINE(A1X<0,空方,突破,0,0),COLOR00CC66;//柱线

均价线:SUM(DC*DV,240)/SUM(DV,240),colormagenta;//

AA:=ZIG(DC1,5),coloryellow;

DIFF1:=-(EMA(AA,26) – EMA(AA,12));

DEA1:=-(EMA(DIFF1,9));

MACD1:=2*(DIFF1-DEA1);

//转向变盘建仓

X:=IF(MACD1<0 AND REF(MACD1,2)>REF(MACD1,1) AND MACD1>REF(MACD1,1),1,0);

DRAWTEXT(X,INDEXC*0.97,"建仓"),coloryellow;

//量价指标

VPT:=SUM(DV/EMA(DV,N)*(DC-REF(DC,1))/REF(DC,1),0);

MAVPT:=EMA(VPT,M);

//均价线金叉

DRAWICON(CROSS(新价,均价线) AND 新价>突破 AND CLOSE>MA(CLOSE,144),均价线,1);

DRAWICON(CROSS(突破,均价线),均价线,1);

//底部

B:=ZIG(DC1,50/5),colorred;

G:=MA(B,2),coloryellow;

D:=CROSS(B,G)*(-0.5),STICK,colormagenta,LINETHICK3;//

DRAWTEXT(D<0,INDEXC*0.95,"底部"),coloryellow;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注