同花顺走势顶底指标公式

////主力动向+主力趋势雷达///

r0:=((IF(ISNULL(ZDMR[-1]),0,ZDMR)+IF(ISNULL(BDMR[-1]),0,BDMR))-(IF(ISNULL(ZDMC[-1]),0,ZDMC)+IF(ISNULL(BDMC[-1]),0,BDMC)))/SHGZG*100;

MA5:=MA(r0,5);

//超买:3.2,coloryellow;//让位趋势决策线

//超卖:0.5,coloryellow;//让位花神线

最小值:=LLV(LOW,10);

最大值:=HHV(HIGH,25);

波动线:=EMA((CLOSE-最小值)/(最大值-最小值)*4,4);

平均线:EMA(波动线,3);

主力攻击:=r0-(ABS(REF(r0,1))+ABS(REF(r0,2))+ABS(REF(r0,3))+ABS(REF(r0,4))+ABS(REF(r0,5))/2)>0 AND 平均线>=REF(平均线,1) AND REF(平均线,1)<REF(平均线,2);

主力撤退:=-((r0+(ABS(REF(r0,1))+ABS(REF(r0,2))+ABS(REF(r0,3))+ABS(REF(r0,4))+ABS(REF(r0,5))/2)<0) AND 平均线<=REF(平均线,1) AND REF(平均线,1)>REF(平均线,2));

DRAWTEXT(主力攻击>0,1.5,"主进"),colorred;

DRAWTEXT(主力撤退<0,2.8,"主退"),colorgreen;

信息:=平均线>=REF(平均线,1);

走强:=CLOSE>MA(CLOSE,20)AND CLOSE>MA(CLOSE,5);

走弱:=CLOSE<MA(CLOSE,10)AND CLOSE<MA(CLOSE,5);

量:=VOL>MA(VOL,5);

STICKLINE(平均线>=REF(平均线,1),波动线,REF(波动线,1),5,0),colorred;

STICKLINE(平均线<REF(平均线,1),波动线 ,REF(波动线,1),5,0),colorgreen;

d:=信息=1 AND REF(信息,1)=0 AND (REF(信息,2)+REF(信息,3)=0) AND 平均线<0.5;

s:=信息=1 AND REF(信息,1)=0 AND (REF(信息,2)+REF(信息,3)=0) AND 走强=1 AND REF(走强,1)=0 AND 量=1;

dd:=平均线>2 AND (信息=0 AND REF(信息,1)=1) AND (REF(信息,2)+REF(信息,3)=2);

tz:=(信息=0 AND REF(信息,1)=1) AND (REF(信息,2)+REF(信息,3)=2) AND MA5<0 AND 走弱=1 AND 平均线>1;

DRAWTEXT(d=1,1.75,’极底’),colorred;

DRAWTEXT(s=1,平均线,’升’);

DRAWTEXT(dd=1,平均线,’顶’);

DRAWTEXT(tz=1,平均线,’下’);

PARTLINE(平均线,平均线>=REF(平均线,1),colorred,平均线<REF(平均线,1),colorgreen);

////机构建仓////

LC:=REF(CLOSE,1);

RSI5:=((SMA(MAX((CLOSE – LC),0),5,1) / SMA(ABS((CLOSE – LC)),5,1)) * 100);

TR1:=SUM(MAX(MAX((HIGH – LOW),ABS((HIGH – REF(CLOSE,1)))),ABS((LOW – REF(CLOSE,1)))),10);

HD:=(HIGH – REF(HIGH,1));

LD:=(REF(LOW,1) – LOW);

DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);

DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);

PDI:=((DMP * 100) / TR1);

MDI:=((DMM * 100) / TR1);

ADX:=MA(((ABS((MDI – PDI)) / (MDI + PDI)) * 100),5);

AV:=(RSI5 + ADX);

WR10:=((100 * (HHV(HIGH,10) – CLOSE)) / (HHV(HIGH,10) – LLV(LOW,10)));

Zcjl:=(RSI5 – WR10);

最佳买入:=(AV + Zcjl);

最佳买入选股:=IF(CROSS(最佳买入,0),1,0);

VAR5:=SMA(最佳买入选股,3,1);

VAR6:=SMA(VAR5,3,1);

VAR7:=SMA(VAR6,3,1);

建仓买点:=IF(CROSS(VAR6,VAR7) AND (VAR6<40),5,0);

DRAWTEXT(建仓买点,0.75,’建仓’),colorred;

////机构利器////

VAR8:=REF(CLOSE,2);

会员:=SMA(MAX(CLOSE-VAR8,0),7,1)/SMA(ABS(CLOSE-VAR8),7,1)*100;

逃亡:=IF(会员< REF(会员,1) AND 会员>79,会员,0);

DRAWTEXT(逃亡,3.1,’逃’),coloryellow;

DRAWTEXT(88>0 AND REF(O,1)/REF(C,1)>1.04 AND REF(L,1)<=688 AND O>REF(C,1)AND C<REF(O,1)AND C/O>=1.01,1,’见底’),colorlired;

DRAWTEXT(C-O>=0 AND O/L>1.05 AND L<=LLV(L,20),1,’绝底’),colorred;

///主力吸货////

VAR11:=REF(LOW,1);

VAR12:=SMA(ABS(LOW-VAR11),3,1)/SMA(MAX(LOW-VAR11,0),3,1)*100;

VAR13:=EMA(IF(CLOSE*1.2,VAR12*10,VAR12/10),3);

VAR14:=LLV(LOW,38);

VAR15:=HHV(VAR13,38);

VAR16:=IF(LLV(LOW,90),1,0);

VAR17:=EMA(IF(LOW<=VAR14,(VAR13+VAR15*2)/2,0),3)/618*VAR16;

Cdxs:=HHV(VAR17,0)/2.6;

STICKLINE(VAR17,0.53,VAR17/Cdxs+0.53,1,0),colorwhite;

////马上成功////

Hua:=(CLOSE – LLV(LOW,14)) / (HHV(HIGH,14) – LLV(LOW,14)) * 1.2 * CLOSE;

Nv1:=EMA(Hua,4);

Nv2:=EMA(Hua,8);

DRAWICON(CROSS(Nv1,Nv2) AND CLOSE/OPEN>1.05,0.5,1);

DRAWICON(CROSS(Nv2,Nv1) AND COUNT(CROSS(Nv1,Nv2) AND CLOSE/OPEN>1.05 ,20) ,3.2,2);

////必涨之星////

Hua2:=SMA(MAX(CLOSE-REF(CLOSE,1),0),16,2)/SMA(ABS(CLOSE/REF(CLOSE,1)),16,2)*100;

Xian=SMA(Hua2,3,1);

Nv3:=SMA(Xian,3,1);

XiNv=3*Xian-2*Nv3;

买入条件:=CROSS(XiNv,Nv3);

卖出条件:=CROSS(Nv3,XiNv);

DRAWICON( 卖出条件,3.3,2),coloryellow;

DRAWICON(买入条件,0.4,222),colorwhite;//必涨之星

Hxn:=IF(CLOSE/REF(CLOSE,1)>1.05 AND HIGH/CLOSE<1.01 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);//花仙女涨停

DRAWTEXT(Hxn>90 AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1) AND COUNT(Hxn>90,30)=1,平均线-0.25, ‘见涨’),,colorlired;

Hxjz:=MA((2*CLOSE+HIGH+LOW)/4,5);//花仙女绝招

Bztd:=Hxjz*89/100;

DRAWTEXT(CROSS(LOW,Bztd),1.25,’必涨’),colorred;

////花神////

花:=EMA(SLOPE(1,1)+C,3),colorred;

女:=EMA(SLOPE(1,1)+C,7),colorblue;

STICKLINE(花>女 ,0.5,0.53,12,0) ,colorred;//花神线,红色开始为买

STICKLINE(花<=女 ,0.5,0.53,12,0),colorgreen;//花神线,绿色开始为卖

///资金抄底///

rj:=((ZDMR[-1]+BDMR[-1])-(ZDMC[-1]+BDMC[-1]))/SHGZG*100;//大单净量

RSI$1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;

RSI$2:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;

RSI$3:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;

相对强弱:=0.5*RSI$1+0.31*RSI$2+0.19*RSI$3;

wave$1:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),3,1);

wave$2:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),5,1);

wave$3:=SMA(100*(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8)),8,1);

短线波段:=0.5*wave$1+0.31*wave$2+0.19*wave$3;

风险系数:=0.5*相对强弱+0.5*短线波段,coloryellow;

CD1:=IF(风险系数<20 AND CLOSE>OPEN AND rj>0,1,0);//波段小于20,股价翻红;

CD2:=IF(风险系数<20 AND LOW>=REF(LOW,1) AND CLOSE>LOW AND rj>0,1,0);//波段小于20,股价未翻红,但未创新低;

CD3:=IF(REF(风险系数,1)<20 AND 风险系数>REF(风险系数,1),1,0);//前一日波段小于20,今日转向;

SIGNALBUY=(CD1=1 OR CD2=1 OR CD3=1);

cd=(SIGNALBUY AND COUNT(SIGNALBUY,3)=1);

DRAWTEXT(cd,0.5,’抄底’),COLOR0099FF;

///金叉共振///

DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;

DEA:=EMA(DIF,9);

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,9,3);

D:=SMA(K,9,3);

GZ:=CROSS(DIF,DEA) AND CROSS(K,D);

DRAWTEXT(GZ,2,’金叉’),COLOR0099FF;

////趋势决策////

大单净差BBD:=BIGBUYCOUNT1+WAITBUYCOUNT1-BIGSELLCOUNT1-WAITSELLCOUNT1;

DIFF:=EMA(大单净差BBD,2) – EMA(大单净差BBD,4),coloryellow;

DIFF2:=EMA(大单净差BBD,6) – EMA(大单净差BBD,12),coloryellow;

m34:=MA(C,34);

m5:=MA(C,5);

r5:=COUNT(大单净差BBD>0,5);

r6:=COUNT(大单净差BBD>0,6);

a1:=IF(C<REF(C,2)*1.0200,1,0);

a2:=IF(C<REF(C,2)*1.0050,1,0);

a3:=IF(C<REF(C,2)*0.0985,1,0);

a4:=IF(C<REF(C,2)*0.0970,1,0);

a5:=IF(DIFF>0,2,0);

a6:=IF(DIFF2>0,2,0);

a7:=IF(C>m34,2,0);

a8:=IF(C>m5,2,0);

a9:=IF(r5>3,2,0);

a10:=IF(r6>3,1,0);

az:=a1+a2+a3+a4+a5+a6+a7+a8+a9+a10;

IF(C<m5)

green:=C<m5;

ELSE IF(az>2.5)

red:=az>2.5;

ELSE green:=az<2.5;

ENTERLONG:=(REF(green,1)=1 AND red=1 ) AND COUNT(REF(green,1)=1 AND red=1,BARSLAST(REF(red,1)=1 AND green=1))=1;

EXITLONG:=REF(red,1)=1 AND green=1 AND COUNT(REF(red,1)=1 AND green=1,BARSLAST(REF(green,1)=1 AND red=1))=1;

IF(C<m5){STICKLINE(C<m5,3.2,3.22,12,0),colorgreen;}

ELSE IF(az>2.5){STICKLINE(az>2.5,3.2,3.22,12,0),colorred;}

ELSE IF(az<=2.5){STICKLINE(az<=2.5,3.2,3.22,12,0),colorgreen;}

DRAWTEXT_FIX(1,0.01,0.2,0,’趋势决策线’),colormagenta;

DRAWTEXT_FIX(1,0.01,1.1,0,’花神线’),colormagenta;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注