同花顺SKDJ背离指标公式

LOWV:=LLV(LOW,9);

HIGHV:=HHV(HIGH,9);

RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);

K:EMA(RSV,3);

D:MA(K,3);

STICKLINE(K>D,K,D,2.5,0),colorred,LINETHICK1,NODRAW;

STICKLINE(D>K,K,D,2.5,0),colorgreen,LINETHICK1,NODRAW;

逃顶线:80,colorwhite;

抄底线:20,colorwhite;

高位谨慎减仓:80,colorred;

A1:=BARSLAST(REF(CROSS(K,D),1));

底背离:REF(CLOSE,A1+1)>CLOSE AND K>REF(K,A1+1) AND CROSS(K,D);

DRAWLINE(A1=0,D,底背离,D,0),colorred,LINETHICK2;

A2:=BARSLAST(REF(CROSS(D,K),1));

顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(D,A2+1)>D AND CROSS(D,K);

DRAWLINE(A2=0,D,顶背离,D,0),colorgreen,LINETHICK2;

DRAWTEXT(底背离>0,D-5,’底背离’),colorred;

DRAWTEXT(顶背离>0,D-5,’顶背离’),colorgreen;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注