同花顺顶底操盘法主图指标公式

MA10:=MA(C,10);

MA20:=MA(C,20);

买线:=ZIG(3,10);

卖线:=MA(买线,3);

换手:=V/CAPITAL*100;

基线:MA(REF(LLV(C,30),1),2),NODRAW;

量能饱和度:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100),NODRAW;

MA5:MA(C,5),COLORF00FF0;

MA8:MA(C,8),coloryellow;

MA13:MA(C,13),COLORE66878;

MA50:MA(C,50),colorwhite;

MA55:MA(C,55),colorgreen;

MA60:MA(C,60),colorred;

MA144:MA(C,144),colorliblue;

X1:=(C+L+H)/3;

X2:=EMA(X1,6);

X3:=EMA(X2,5);

STICKLINE(CROSS(买线,卖线),O,C,9,0),COLOR00AAFF;

STICKLINE(买线<卖线,H,L,0,0),colorgreen;

STICKLINE(买线<卖线,C,O,9,0),Color007700;

STICKLINE(买线<卖线,C,O,8,0),Color008E00;

STICKLINE(买线<卖线,C,O,7,0),Color009900;

STICKLINE(买线<卖线,C,O,6,0),Color00A600;

STICKLINE(买线<卖线,C,O,5,0),Color00B500;

STICKLINE(买线<卖线,C,O,4,0),Color00C600;

STICKLINE(买线<卖线,C,O,3,0),Color00D500;

STICKLINE(买线<卖线,C,O,2,0),Color00E600;

STICKLINE(买线>=卖线,H,L,0,0),Color0000FF;

STICKLINE(买线>=卖线,C,O,9,0),Color0000A3;

STICKLINE(买线>=卖线,C,O,8,0),Color0000B7;

STICKLINE(买线>=卖线,C,O,6,0),Color0000C8;

STICKLINE(买线>=卖线,C,O,5,0),Color0000D9;

STICKLINE(买线>=卖线,C,O,4,0),Color0000CD;

STICKLINE(买线>=卖线,C,O,3,0),Color0000E9;

STICKLINE(买线>=卖线,C,O,2,0),Color0000EA;

STICKLINE(买线>=卖线,C,O,1,0),Color0000FF;

VARF1:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR101:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR111:=VARF1<REF(VAR101,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

游资:=(VAR111 AND COUNT(VAR111,30)=1 AND 买线>=卖线);

DRAWTEXT(游资,(基线*0.97),’–游资进’),colorliblue;

STICKLINE(游资,(基线*0.96),(基线+0.2),9,0),colorliblue;

VARS1:=(C-LLV(L,36))/(HHV(H,36)-LLV(L,36))*100;

VARS2:=SMA(VARS1,3,1);

VARS3:=SMA(VARS2,3,1);

VARS4:=SMA(VARS3,3,1);

抄底:=((FILTER((CROSS(VARS3,VARS4) AND VARS3<20),10)=1) AND 买线>=卖线);

DRAWTEXT(抄底,(基线*0.94),’–抄底’),COLORFF00FF;

STICKLINE(抄底,(基线*0.92),基线,9,0),COLORFF00FF;

YY:=(CROSS(X2,X3) AND (买线>=卖线));

DRAWTEXT(YY,(L*0.99),’–精准买’),coloryellow;

STICKLINE(YY,C,(L*0.98),9,0),coloryellow;

F:=100*(C-REF(C,1))/REF(C,1);

S1:=IF(C<REF(O,1) AND F<0,1,0);

S2:=IF(C<REF(O,2) AND F<0,1,0);

短买点:=((CROSS((SMA(MAX(C-(REF(C,1)),0),4.1,1)/SMA(ABS(C-(REF(C,1))),4.1,1)*100),11)*1) AND S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND 换手>=3 AND 买线>=卖线);

DRAWTEXT(短买点,(基线*0.94),’–短买点’),COLORFF00FF;

STICKLINE(短买点,(基线*0.92),(基线*0.98),9,0),COLORFF00FF;

VAR5:=(3*(SMA(SMA(((C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100),3,1),3,1)/28.57)-2*(EMA((SMA(SMA(((C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100),3,1),3,1)/28.57),5)));

奔牛:=(CROSS(VAR5,(SMA(SMA(((C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100),3,1),3,1)/28.57)) AND 买线>=卖线);

DRAWTEXT(奔牛,(基线*0.98),’–奔牛’),COLOR00AAFF;

STICKLINE(奔牛,(基线*0.96),基线,9,0),COLOR00AAFF;

VARQ1:=EMA(CLOSE,3);

VARQ2:=EMA(CLOSE,21);

VARQ3:=BARSLAST(CROSS(VARQ2,VARQ1))>15;

VARQ4:=VOL>MA(VOL,5)*2 AND VOL<MA(VOL,5)*5;

黑马:=((CROSS(VARQ1,VARQ2) AND VARQ4 AND VARQ3) AND 买线>=卖线);

DRAWTEXT(黑马,(基线*0.98),’–黑马’),COLORFF6600;

STICKLINE(黑马,(基线*0.96),基线,9,0),COLORFF6600;

波段买点:=CROSS((ZIG(3,10)),(MA((ZIG(3,10)),3)));

DRAWTEXT(波段买点,(基线*0.98),’–波段买’),color00aaff;

STICKLINE(波段买点,(基线*0.96),基线,9,0),colorlired;

VARDD:=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3));

DRAWTEXT((VARDD=1),(H*1.05),’波段卖’),colorwhite;

STICKLINE((VARDD=1),(H*1.01),(H*1.03),9,0),colorwhite;

大黑马:=(IF(CROSS((MA(3*SMA(((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100,6,1)-2*SMA(SMA(((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100,5,1),5,1),2)),0)AND EMA(3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),5)<40,8,0) AND 买线>=卖线);

DRAWTEXT(大黑马,(基线*0.94),’-大黑马’),colorblue;

STICKLINE(大黑马,(基线*0.92),基线,9,0),colorblue;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注