通达信人股合一选股指标公式

N:=5;

XA_1:=100*VOL/(FINANCE(7)/100);

XA_2:=(REF(XA_1,1)+REF(XA_1,2)+REF(XA_1,3)+REF(XA_1,4)+REF(XA_1,5))/(5*240);

XA_3:=XA_1/240;

XA_4:=XA_3/XA_2;

XA_5:=XA_1/FROMOPEN;

XA_6:=XA_5/XA_2;

XA_7:=IF(ISLASTBAR,XA_6,XA_4);

XA_8:=MA(CLOSE,5);

XA_9:=MA(CLOSE,10);

XA_10:=MA(CLOSE,20);

XA_11:=MA(CLOSE,30);

XA_12:=MA(CLOSE,60);

XA_13:=MA(CLOSE,120);

XA_14:=MA(CLOSE,240);

XA_15:=MAX(MAX(XA_8,XA_9),MAX(XA_10,XA_11));

XA_16:=MIN(MIN(XA_8,XA_9),MIN(XA_10,XA_11));

XA_17:=XA_15/XA_16;

XA_18:=XA_8>XA_9 AND XA_9>XA_10;

XA_19:=REF(BARSLASTCOUNT(CLOSE<HHV(CLOSE,30))>=10,1)=1;

XA_20:=BARSLAST(BARSLASTCOUNT(XA_17<1.03)>=N)<=3;

XA_21:=REF(CLOSE,1)/REF(CLOSE,4)<=1.05;

XA_22:=HIGH/REF(CLOSE,1)>=1.01 AND XA_7>=1.3 AND XA_7<=7;

XA_23:=DATE<1251231;

XG1:FILTER(XA_18 AND XA_19 AND XA_20 AND XA_21 AND XA_22 AND XA_23,10);

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注