通达信如履薄冰精品组合指标公式

MA5:MA(CLOSE,5);

MA10:MA(CLOSE,10);

MA20:MA(CLOSE,20);

MA30:MA(CLOSE,30);

成本价:MCST,COLORLICYAN;{市场成本,无未来}

DRAWTEXT(CROSS(C,MCST),L-0.3,’上穿成本’),COLORLICYAN;

上穿成本选股:STICKLINE((CROSS(C,MCST)),L-0.1,L-0.3,1,0)COLORLICYAN;

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);{主体K线,无未来}

VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

{STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 ORVAR8

OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;{红1}

VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

{STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 ORVAR14

OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),1.0,0),COLORFFCC66;}

VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13

OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

黄柱体选股:STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),4,0),COLORYELLOW;

VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8

OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;

STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,1),COLOR00FF00{98FD};

STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLORRED;

STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLORBLUE;

IF(MA5>=REF(MA5,1) AND MA5>=MA10,MA5,DRAWNULL),COLORRED,LINETHICK2;

IF(MA10>=REF(MA10,1) AND MA10>=MA20,MA10,DRAWNULL),COLORRED,LINETHICK2;

IF(MA20>=REF(MA20,1) AND MA20>=MA30,MA20,DRAWNULL),COLORRED,LINETHICK2;

五日十日选:DRAWTEXT(CROSS(MA5,MA10),MA5,’○’),LINETHICK2, COLORYELLOW;

趋势线:=MA((CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ,2);{抄大底,无未来}

大底十字选股:DRAWICON(趋势线<-20,L-0.6,23);

AA:=BARSCOUNT(C);{时间窗,无未来}

AH:=HHV(H,200);

AL:=LLV(L,200);

A0:=(AH-AL)/40;

B1:=L-A0;

STICKLINE((AA+0)/34=FLOOR((AA+0)/34),B1,B1-1.5*A0,1,0)COLORF00FF0;

DRAWTEXT((AA+0)/34=FLOOR((AA+0)/34),B1-1*A0,’时间窗,变盘’)COLORYELLOW;

VAR20:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;{双底KDJ,无未来}

K1:=SMA(VAR20,3,1),COLORFFFFFF;

D1:=SMA(K1,3,1),COLORFFFFFF,LINETHICK2;

VAR21:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;

K2:=SMA(VAR21,3,1),COLOR0000FF;

D2:=SMA(K2,3,1),COLOR0000FF,LINETHICK2;

VAR22:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;

K3:=SMA(VAR22,3,1),COLORFF8800;

D3:=SMA(K3,3,1),COLORFF8800,LINETHICK2;

VAR23:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;

K4:=SMA(VAR23,3,1),COLOR00FF00;

D4:=SMA(K4,3,1),COLOR008000;

DIBU:=K1<20 AND D1<20 AND K2<20 AND D2<20 AND K3<20 AND D3<20 AND D4<20;

底部:=DIBU=1,COLORYELLOW;

双底KDJ选股:DRAWICON(DIBU,L-0.6,17);

B:=TROUGH(CLOSE,10,1)*1.02;{箱底选股有未来}

VAR24:=IF(TROUGHBARS{波谷位置,未来函数}(3,16,1)=0 AND HIGH>L+0.04,10,0);

VAR25:=ZIG{未来函数}(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

VAR26:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

VAR27:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

VAR28:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

VAR29:=CLOSE/MA(CLOSE,40)*100<78;

VAR30:=CLOSE/MA(CLOSE,60)*100<74;

VAR31:=HIGH>LOW*1.051;

VAR32:=VAR28 AND COUNT(VAR31,5)>1;

VAR33:=(C=L AND H=L);

VAR34:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

单枪出击选股:{无未来}DRAWICON((VAR32 AND (VAR29 OR VAR30) AND NOT(VAR33) AND L<B),L-0.4,27)COLORLIMAGENTA;

组合买1选股:{有未来}DRAWICON((VAR24 AND L<B),L-0.2,26)COLORYELLOW;

组合买2选股:{有未来}DRAWICON(((VAR25+VAR26+VAR27+VAR28) AND L<B),L-0.3,25)COLORRED;

DRAWTEXT(VAR26,L-0.4,’★’)COLORRED;

VAR35:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);{大资金活动有未来}

大资金A选:{有未来}DRAWTEXT(VAR35 AND COUNT(VAR35,30)=1,LOW*0.98,’⊙大资金活动A’),LINETHICK1,COLORFF00FF;

VAR36:=(100 – ((90 * (HHV(HIGH,20) – CLOSE)) / (HHV(HIGH,20) – LLV(LOW,20))));

VAR37:=(100 – MA(((100 * (HHV(HIGH,5) – CLOSE)) / (HHV(HIGH,5) – LLV(LOW,5))),34));

AABB:=IF(CROSS(VAR36,MA(VAR37,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;

大资金B选:{无未来+有未来}DRAWICON((CROSS(VAR36,MA(VAR37,5)) AND (VAR35 AND COUNT(VAR35,30)=1)),L-0.8,22);

VAR38:=4*SMA((CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*100,5,1)-

3*SMA(SMA((CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*100,5,1),3.2,1),COLORRED,LINETHICK1;{吃庄家肉,无未来}

VAR39:=8,COLORGREEN,LINETHICK1;

吃庄家肉选股:DRAWICON(CROSS(VAR38,VAR39),L-0.8,15);

WZ:=CURRBARSCOUNT;{主图画面文字}

DRAWTEXT(WZ=1,HHV(C,50)*0.99,’ ★红钻=组合买2 有’)COLORRED;

DRAWTEXT(WZ=1,HHV(C,50)*0.97,’ 黄钻=组合买1 有’)COLORYELLOW;

DRAWTEXT(WZ=1,HHV(C,50)*0.94,’ 绿钻=单枪出击 无’)COLORGREEN;

DRAWTEXT(WZ=1,HHV(C,50)*0.91,’ 苹果=双底KDJ 无’),COLORYELLOW;

DRAWTEXT(WZ=1,HHV(C,50)*0.88,’ 十字=抄大底 无’),COLORWHITE;

DRAWTEXT(WZ=1,HHV(C,50)*0.85,’ 手机=大资金B 无+有’),COLORLIBLUE;

DRAWTEXT(WZ=1,HHV(C,50)*0.82,’ 黄人=吃庄家肉 无’)COLORYELLOW;

{注1:上面的“有”于“无”代表有未来函数和无未来函数};

{注2:本指标包含了11项选股功能};

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注