通达信庄家杀手MACD指标公式

DIF:(EMA(CLOSE,12) – EMA(CLOSE,26)),COLORRED,NODRAW;

DEA:EMA(DIF,9),COLOR00FFFF,NODRAW;

MACD:2*(DIF-DEA),NODRAW;

DIFK:=EMA(DIF,3);

DIFD:=EMA(DIFK,3);

DKK:4*DIF-3*DEA,COLORFF00FF,NODRAW;

DDD:EMA(DKK,5),COLOR2588FF,NODRAW;

TRLSX1:= MAX(MAX((HHV(DIF,13)-LLV(DIF,13)),ABS(REF(DIF,1)-HHV(DIF,13))),ABS(REF(DIF,1)-LLV(DIF,13)));

TRLSX2:=EMA(TRLSX1,13);

TRLSX3:=REF(DIF,1)-REF(TRLSX2,1);

支撑:HHV(TRLSX3,13),COLORFFFFFF,NODRAW;

RSV14:=(CLOSE – LLV(LOW,14))/(HHV(HIGH,14) – LLV(LOW,14))-0.5;

K14:=EMA(RSV14,3),COLORFF00FF,NODRAW;

D14:=EMA(K14,3),COLORGREEN,NODRAW;

J14:=3*K14-2*D14;

DRAWBAND(DIF,RGB(200,50,55),DEA,RGB(50,100,10));

MACDXG2:=REF(COUNT(DIF>0 AND MACD<0 AND MACD<REF(MACD,1),4)=4,1) AND MACD>REF(MACD,1);

STICKLINE(MACDXG2,MACD*1.2,0,2.8,0),COLORRED;

STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR000055;

STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR000099;

STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLOR0000BB;

STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR888888;

STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLORBBBBBB;

STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLORDDDDDD;

STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLOR3377AA;

STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLOR3388BB;

STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLOR4499CC;

STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLORFF3300;

STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLORFF5500;

STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLORFF7700;

{股票资源网-股票公式网站 www.91goo.com}

STICKLINE(J14<-0.5,0,0.15,1.8,0),COLORFF00FF;

支撑,COLORFFFFFF;

IF(C>0,DIF,DRAWNULL),COLORRED,LINETHICK1;

IF(C>0,DEA,DRAWNULL),COLOR00FFFF,LINETHICK1;

IF(DEA<REF(DEA,1),DEA,DRAWNULL),COLORBE7F6F,LINETHICK1;

IF(DIF<=REF(DIF,1),DIF,DRAWNULL),COLORBLUE,LINETHICK1;

IF(C,DKK,DRAWNULL),COLORFF00FF,LINETHICK1;

IF(DKK<=REF(DKK,1),DKK,DRAWNULL),COLORCYAN,LINETHICK1;

IF(C,DDD,DRAWNULL),COLOR2255FF,LINETHICK1;

IF(DDD<=REF(DDD,1),DDD,DRAWNULL),COLOR33FF33,LINETHICK1;

KDJXG:=REF(COUNT(J14<REF(J14,1),5)>=3,1) AND REF(J14,1)<-0.4 AND J14>REF(J14,1);

DRAWICON(FILTER(KDJXG,3),MACD*1.2,11),COLORFF00EE;

准备介入点:=REF(CROSS(0,MACD),3) AND COUNT(DIF>0 AND MACD<REF(MACD,1),4)=4 ;

DRAWICON(准备介入点,0.05,9);

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注