通达信macd美如画指标公式

DIFF1:= EMA(C,3) – EMA(C,13);

DEA1 := EMA(DIFF1,9);

MACD1:= 2*(DIFF1-DEA1)*10;

DIFF2:= EMA(C,5) – EMA(C,26);

DEA2 := EMA(DIFF2,9);

MACD2:= 2*(DIFF2-DEA2)*10;

DIFF3:= EMA(C,7) – EMA(C,89);

DEA3 := EMA(DIFF3,21);

MACD3:= 2*(DIFF3-DEA3)*10;

{DRAWGBK(C>0,COLORRGB(255,255,220),COLORRGB(5,100,255),1),COLORF80606;}

{股票资源网-股票公式网站 www.91goo.com}

DRAWBAND(MACD3,RGB(58,158,0),0,RGB(100,100,100));

DRAWBAND(MACD2,RGB(25,125,0),0,RGB(85,85,85));

DRAWBAND(MACD1,RGB(0,100,0),0,RGB(65,65,65));

DRAWBAND(IF(MACD3>=1,-ABS(MACD3)*0.6,0),RGB(35,35,35),0,RGB(35,35,35));

DRAWBAND(IF(MACD1>=1,-ABS(MACD1)*0.6,0),RGB(15,15,15),0,RGB(15,15,15));

X1:=MA(LLV(C,8)*1.1,13);

X2:=MA(HHV(C,21)*0.9,13);

X3:=MA(LLV(INDEXC,8)*1.1,13);

X4:=MA(HHV(INDEXC,21)*0.9,13);

资金进出:=3*(MA(C,1)-(X1+X2)/2-(X1+X2)/2*((X3+X4)/2-EMA(INDEXC,3))/((X3+X4)/2));

STICKLINE(资金进出<0,资金进出,0,0.01,0),COLORCYAN;

STICKLINE(资金进出>=0,资金进出,0,0.01,0),COLORFF8BFF;

红持: (SMA(CLOSE,2,1)-EMA(LLV((CLOSE+LOW)/2,10),21))/MA(LLV((CLOSE+LOW)/2,10),21)*25,LINETHICK0,COLORRED;

白减: (SMA(CLOSE,4,1)-EMA(LLV((CLOSE+LOW)/2,10),21))/MA(LLV((CLOSE+LOW)/2,10),21)*25,LINETHICK0,COLORFFFFFF;

DRAWBAND(红持,RGB(255,0,0),白减,RGB(255,251,240));

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注