通达信决定量能指标公式

历史量比:=VOL/MA(VOL,5);

换手:=(VOL*100/CAPITAL);

十日换手:SUM(换手,10);

{主动买卖量}

AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

主买:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL /2)),POINTDOT,COLORRED;

主卖:=IF(CLOSE>OPEN,AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,AA*(HIGH-LOW),VOL /2)),COLORCYAN,POINTDOT;

{STICKLINE(主买,0,主买,2,0),COLORRED;

STICKLINE(主卖,0,主卖,0.8,0),COLOR004000;}

ZM:=EMA(HHV(主买,34),1),COLOR999999;

DRAWBAND(ZM,RGB(0,0,100),0,RGB(0,0,0));

{盘中虚拟-TDX}

T5:=FROMOPEN-INTPART(FROMOPEN/5)*5;

VV5:=IF(CURRBARSCOUNT=1 AND PERIOD=1,VOL*5/T5,DRAWNULL);

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=1,VV5,0,4,-1),COLORFFFFFF;

T15:=FROMOPEN-INTPART(FROMOPEN/15)*15;

VV15:=IF(CURRBARSCOUNT=1 AND PERIOD=2,VOL*15/T15,DRAWNULL);

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=2,VV15,0,4,-1),COLORFFFFFF;

T30:=FROMOPEN-INTPART(FROMOPEN/30)*30;

VV30:=IF(CURRBARSCOUNT=1 AND PERIOD=3,VOL*30/T30,DRAWNULL);

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=3,VV30,0,4,-1),COLORFFFFFF;

T60:=FROMOPEN-INTPART(FROMOPEN/60)*60;

VV60:=IF(CURRBARSCOUNT=1 AND PERIOD=4,VOL*60/T60,DRAWNULL);

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=4,VV60,0,4,-1),COLORFFFFFF;

{股票资源网-股票公式网站 www.91goo.com}

VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,4,-1),COLORFFFFFF;

{———————————-}

VAR2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

获利盘: WINNER(CLOSE)*100;

VAR3:=SMA(VAR2,3,1);

VAR4:=SMA(VAR3,9,1);

VAR5:=3*VAR3-2*VAR4;

VAR6:=VOL;

涨跌1:= (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

角度: (CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

{换手: VOL/CAPITAL*100,COLOR008FFF;}

VAR7:=SUM(换手,30);

VAR8:=LLV(INDEXL,5);

VAR9:=HHV(INDEXH,5);

VARA:=EMA((INDEXC-VAR8)/(VAR9-VAR8)*100,4);

VARB:=MA(EMA(0.667*REF(VARA,1)+0.333*VARA,2),9);

VARC:=MA(VARB,30);

VARD:=EMA(获利盘,4);

本盘亿股:= CAPITAL/1000000;

振幅1:= (HIGH-LOW)/REF(CLOSE,1)*100;

VARF:=(涨跌1>VARD AND 角度<-30 AND 涨跌1>3);

CROSS(VARB,VARC) AND VARC<29;

STICKLINE(VOL AND VAR5>VAR4 AND C>=O,0,VOL,3,1),COLORRED;

STICKLINE(VOL AND VAR5>VAR4 AND C<O,0,VOL,3,0),COLORFFFF00;

STICKLINE(VOL AND VAR5<VAR4 AND C>=O,0,VOL,3,1),COLOR00FF00;

STICKLINE(VOL AND VAR5<VAR4 AND C<O,0,VOL,3,1),COLOR00FF00;

STICKLINE(VOL AND VAR4<16,-10,VOL*0.5,3,0),COLOR00FFFF;

STICKLINE(主买,0,主买,1.5,0),COLORRED;

STICKLINE(主卖,0,主卖,0.8,0),COLOR004000;

V5: MA(VOL,5),COLORWHITE;

V60: MA(VOL,60),COLOR00FFFF;

EMA(HHV(主买,34),1),COLOR555555,LINETHICK1;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注