通达信箱体顶底主图指标公式

MA1:MA(CLOSE,17),COLORFF00FF,LINETHICK2;

MA2:IF(MA1>=REF(MA1,1),MA1,DRAWNULL),COLORFF00FF,LINETHICK1;

MA3:IF(REF(MA1,1)>MA1,MA1,DRAWNULL),COLOR59A100,LINETHICK2;

箱顶:MA(REF(HHV(C,10),1),1),LINETHICK1,COLORFFA188;

箱底:MA(REF(LLV(C,10),1),1),LINETHICK1,COLORFFA188;

VARB:=IF(CLOSE>150,91.3,0.913);

MA4:MA(CLOSE,2),COLOR0300B2,LINETHICK2;

MA5:IF(MA4>=REF(MA4,1),MA4,DRAWNULL),COLORRED,LINETHICK1;

MA6:IF(REF(MA4,1)>MA4,MA4,DRAWNULL),COLORFFEAC8,LINETHICK2;

下沿:INTPART(CLOSE/VARB )*VARB,POINTDOT,LINETHICK4,COLOR5B6EE0;

上沿:下沿+VARB,POINTDOT,LINETHICK4,COLOR00FF00 ;

中线:(下沿+上沿)/2,POINTDOT,COLORWHITE,LINETHICK4;

STICKLINE(MA1>MA4,MA1,MA4,0,0),COLORFFA610;

STICKLINE(MA1<MA4,MA4,MA1,0,0),COLOR00FFFF;

STICKLINE((C<O),OPEN,CLOSE,3,0),COLORCC9A85;

STICKLINE((C<O),HIGH,LOW,0,0),COLORCCBBAD;

STICKLINE((C>=O),OPEN,CLOSE,3,0),COLOR0000DD;

STICKLINE((C>=O),HIGH,LOW,0,0),COLOR0000FF;

{股票资源网-股票公式网站 www.91goo.com}

顶压:HHV(MA(H,11),50),COLOR00FFFF;

短压:HHV(MA(H,11),15),COLOR0090E0;

XL1:=LLV(MA(H,11),1);

趋势:IF(XL1>=短压,短压,XL1),COLORFFFFFF;

X1:=(3*C+H+L+O)/6;

X2:=EMA(X1,10);

X3:=REF(X2,1);

X4:=(REF(HIGH,1)+REF(LOW,1))/2;

X5:=MA(CLOSE,21)+2*STD(CLOSE,21);

X6:=REF(CLOSE,1);{出货}

X7:=SMA(MAX(CLOSE-X6,0),7,1)/SMA(ABS(CLOSE-X6),7,1)*100;

X8:=CROSS(79,X7);

X9:=FILTER(X8,4);{40}

WZ1:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);{减}

WZ2:=POW(MA(LOW,5),2)+MA(LOW,5);

WZ3:=POW(MA(HIGH,5),2)+MA(HIGH,5);

WZ4:=(WZ1-LLV(WZ2,9))/(HHV(WZ3,9)-LLV(WZ2,9))*150+65;

DK:=SMA(WZ4,3,1)*1.5;

DD:=SMA(DK,3,1);

DJ:=3*DK-2*DD;

WZ5:= EMA(CLOSE,12) – EMA(CLOSE,26);

WZ6:= EMA(WZ5,9);

WZ7:= 2*(WZ5-WZ6);{50}

WZ8:= REF(WZ7,1);

WZ9:= CROSS(WZ8,WZ7) AND WZ8>0;

DRAWTEXT(WZ9 AND DJ>250,H,’←减’),COLORBCFF8B;

VAR11:=EMA(CLOSE,8);{起步}

VAR2:=EMA(VAR11,20);

VAR3:=CROSS(VAR11,VAR2);

VAR4:=VAR11<MA(CLOSE,120);

VAR5:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;{逃命}

VAR6:=SMA(VAR5,5,1);

VAR7:=SMA(VAR6,8,1);{60}

VAR8:=CROSS(VAR6,VAR7) AND VAR7<20;

VAR9:=CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR8;

VARA:=IF(CLOSE>1000,VAR8,VAR9);

起步:= VAR3 AND VAR4;

逃遁:= VARA;

STICKLINE(X2>X3,X2*0.98,X2,6,1),COLOR0000FF;

STICKLINE(X2<X3,X2*0.98,X2,6,1),COLORF10011;

WW1:= SUM( MA(C,10),9)/10.110;

XX1:=MA(LOW,2)*0.96;

XX2:=MA(LOW,26)*0.85;

XX3:= REF(XX1,1)<XX2 AND REF(XX1,1)<XX1 AND REF(XX1,1)<REF(XX1,2);

VAR1:=INDEXC;

VAR12:=MA(VAR1,6);

VAR13:=MA(VAR1,24);

VAR14:=MA(VAR1,32);

VAR15:=MA(VAR1,62);

VAR16:=MA(VAR1,105);

VAR17:=VAR15<REF(VAR15,1) AND VAR6<REF(VAR16,1) AND VAR15<VAR6*0.98;

VAR18:=VAR14>VAR12*1.11 AND VAR13>VAR12*1.095;

VAR19:=VAR12>VAR1*0.95;

VAR111:=EMA(WINNER(CLOSE)*70,3);

VAR112:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);

VAR113:=CLOSE/MA(CLOSE,40)*100<76;

VAR114:=CLOSE/MA(CLOSE,60)*100<74;

VAR115:=HIGH>LOW*1.051;

VAR116:=VAR115 AND COUNT(VAR15,5)>1;

VAR117:=VAR17 AND VAR8 AND VAR19 AND CLOSE/COST(8)<=0.8

AND (CLOSE>OPEN OR CLOSE<OPEN)

AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1))

AND CLOSE>0.1 OR VAR16

AND (VAR113 OR VAR114) AND VAR112<20 AND VAR111<20

AND (WINNER(CLOSE*125/100)-WINNER(CLOSE))*100<7.5 OR

TROUGHBARS(3,15,1)<4 AND CROSS(EMA(CLOSE,21)-EMA(CLOSE,8),

EMA(EMA(CLOSE,21)-EMA(CLOSE,8),5));

XL11:=EMA(CLOSE,10)/100;{70}

XL2:= MA((XL11-REF(XL11,10))/REF(XL11,10),3)*100;

XL3:= MA(XL2,3);

XL4:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1);

DRAWTEXT(IF(CROSS(3*XL4-2*SMA(XL4,3,1),8),87,0)

AND X2>X3,L-0.1,’←●反弹’),COLORGREEN;

DRAWTEXT(IF(CROSS((VAR11-LLV(VAR1,4))/(HHV(VAR11,4)-LLV

(VAR11,4))*4*25,87.5) AND

VAR1<40,87,0) AND X2>X3,L-0.2,’←●短买’),COLORFFBBD8;

DRAWTEXT(CROSS(VAR1,10) AND X2>X3,L-0.3,’←●买’),COLOR89B2FF;

DRAWTEXT(IF(CROSS(2*(EMA((CLOSE*2+HIGH+LOW)/4,12)-EMA

((CLOSE*2+HIGH+LOW)/4,26)-EMA(EMA((CLOSE*2+HIGH+LOW)/

4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26),2))*5.8,0.47),LOW,0)

AND X2>X3,L-0.4,’←●加仓’),COLORFF5ED8;{80}

LL1:=(EMA(CLOSE,3) – EMA(CLOSE,13));

LL2:=EMA(LL1,9);

LL3:=BARSLAST(CROSS(LL1,LL2));

LL4:=REF(LL3,LL3+1);

LL5:=LL2<REF(LL2,LL4);

变盘:=CROSS(LL1,LL2) AND LL5;

DRAWTEXT(起步>0,L,’★起步?’),COLOR00FF00;

STICKLINE(起步>0,C*1.05,C,7,0),COLORRED;

DRAWTEXT(逃遁>0,H*1.04,’●←逃’),COLOR7FFFD6;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注