通达信薛斯箱体主图指标公式

MA(C,5),COLOR00FF00;

X1A:=30;

X1B:HHV(C,X1A),COLORFF5500;

X1C:=IF(ISLASTBAR,BARSLAST(C=CONST(X1B))+1,1/0);

X1D:=IF(X1C=1,’ 1′,IF(X1C=2,’ 2′,IF(X1C=3,’ 3′,IF(X1C=4,’ 4′,IF(X1C=5,’ 5′,

IF(X1C=6,’ 6′,IF(X1C=7,’ 7′,IF(X1C=8,’ 8′,IF(X1C=9,’ 9′,IF(X1C=10,’ 10′,

IF(X1C=11,’ 11′,IF(X1C=12,’ 12′,IF(X1C=13,’ 13′,IF(X1C=14,’ 14′,IF(X1C=15,’ 15′,

IF(X1C=16,’ 16′,IF(X1C=17,’ 17′,IF(X1C=18,’ 18′,IF(X1C=19,’ 19′,IF(X1C=20,’ 20′,

IF(X1C=21,’ 21′,IF(X1C=22,’ 22′,IF(X1C=23,’ 23′,IF(X1C=24,’ 24′,IF(X1C=25,’ 25′,

IF(X1C=26,’ 26′,IF(X1C=27,’ 27′,IF(X1C=28,’ 28′,IF(X1C=29,’ 29′,IF(X1C=30,’ 30′,’ 0′))))))))))))))))))))))))))))));

X1E:DRAWTEXT(ISLASTBAR,X1B,X1D),COLORFF5500;

{股票资源网-股票公式网站 www.91goo.com}

X2A:=30;

X2B:LLV(C,X2A),COLORFF00FF;

X2C:=IF(ISLASTBAR,BARSLAST(C=CONST(X2B))+1,1/0);

X2D:=IF(X2C=1,’ 1′,IF(X2C=2,’ 2′,IF(X2C=3,’ 3′,IF(X2C=4,’ 4′,IF(X2C=5,’ 5′,

IF(X2C=6,’ 6′,IF(X2C=7,’ 7′,IF(X2C=8,’ 8′,IF(X2C=9,’ 9′,IF(X2C=10,’ 10′,

IF(X2C=11,’ 11′,IF(X2C=12,’ 12′,IF(X2C=13,’ 13′,IF(X2C=14,’ 14′,IF(X2C=15,’ 15′,

IF(X2C=16,’ 16′,IF(X2C=17,’ 17′,IF(X2C=18,’ 18′,IF(X2C=19,’ 19′,IF(X2C=20,’ 20′,

IF(X2C=21,’ 21′,IF(X2C=22,’ 22′,IF(X2C=23,’ 23′,IF(X2C=24,’ 24′,IF(X2C=25,’ 25′,

IF(X2C=26,’ 26′,IF(X2C=27,’ 27′,IF(X2C=28,’ 28′,IF(X2C=29,’ 29′,IF(X2C=30,’ 30′,’ 0′))))))))))))))))))))))))))))));

X2E:DRAWTEXT(ISLASTBAR,X2B,X2D),COLORFF00FF;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注