通达信黄金MACD指标公式

SHORT:=12;LONG:=26;M:=9;

DIFF : EMA(CLOSE,SHORT) – EMA(CLOSE,LONG);

DEA : EMA(DIFF,M);

MACD : 2*(DIFF-DEA), COLORSTICK,COLOR5454FF;

DD:=C=HHV(C,180);

EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;

CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;

上升背离:(CC AND EE)*DEA,COLOR00FFFF;

{股票资源网-股票公式网站 www.91goo.com}

顶背离:(DD AND EE AND DEA< HHV(DEA,180))*DEA,STICK,LINETHICK3,COLORGREEN;

FF:=C=LLV(C,180);

GG:= DEA> REF(DEA,1) AND REF(DEA> REF(DEA,1),1)=1;

LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;

下降背离:(LL AND GG)*DEA,COLORMAGENTA;

底背离:(FF AND GG AND DEA> LLV(DEA,180))*DEA,STICK,LINETHICK3,COLORRED;

MM:=IF(MACD< 0,MACD,0);

JJ:=MM> REF(MM,1);

ZZ:=REF(JJ,1)=1;

介入区:(JJ AND ZZ)*DEA,POINTDOT,COLORYELLOW;{MACD蓝柱缩短—指今日比昨天短}

STICKLINE(介入区=DEA,DEA,DIFF,0.5,1),COLORYELLOW;

DRAWTEXT(CROSS(DIFF,DEA ),0,’金↗’),COLORYELLOW;

DRAWTEXT(CROSS(DEA,DIFF ),0,’死↘’),COLORFFFF00;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注