通达信均线速度指标公式

P1:=5;P2:=30;

A1:=MA(CLOSE,P1);A2:=REF(A1,1);J1:(A1-A2)/A2*100;MJ1:MA(J1,3);

A3:=MA(CLOSE,P2);A4:=REF(A3,1);J2:(A3-A4)/A4*100;MJ2:=MA(J2,10);

A5:=MA(C,10);A6:=REF(A5,1);

J3:=(A5-A6)/A6*100;MJ3:=MA(J3,5);

向上拐点:IF(COUNT(CROSS(J1,0),3)>=1 AND MJ1>MJ3 AND MJ3>REF(MJ3,1) AND J3>=0 AND J1>REF(J1,1),5,0) ,COLORRED,LINETHICK2;

向下拐点:IF(CROSS(0,J1)>=1 AND MJ3<REF(MJ3,1) AND MJ2<REF(MJ2,2) AND MJ3<MJ2,-5,0),COLORGREEN,LINETHICK2;

{股票资源网-股票公式网站 www.91goo.com}

0,COLORWHITE;

STICKLINE(J1>0 AND J2>0,J1,0,2,0),COLORRED;

STICKLINE(J1<0 AND J2>0,0,J1,2,0),COLORYELLOW;

STICKLINE(J1>0 AND J2<0,J1,0,2,0),COLORMAGENTA;

STICKLINE(J1<0 AND J2<0,0,J1,2,0),COLORGREEN;

DRAWICON(CROSS(J1,MJ1) AND COUNT(MJ1<-3,3)>=1 ,J1*1.5,1);

DRAWICON(CROSS(MJ1,J1) AND COUNT(MJ1>3,3)>=1,J1*1.8,2);

选股:IF(CROSS(J1,MJ1) AND COUNT(MJ1<-2,3)>=1,2,0),COLORYELLOW,LINETHICK2;

B1:=BARSLAST(REF(CROSS(J1,MJ1) AND MJ1<0,1));

底背离:=REF(CLOSE,B1+1)>CLOSE AND J1>REF(J1,B1+1) AND CROSS(J1,MJ1);

DRAWLINE(B1=0,MJ1,底背离,MJ1,0),COLORRED,LINETHICK3;

B2:=BARSLAST(REF(CROSS(MJ1,J1) AND MJ2>0,1));

顶背离:=REF(CLOSE,B2+1)<CLOSE AND REF(MJ1,B2+1)>J1 AND CROSS(MJ1,J1);

DRAWLINE(B2=0,MJ1,顶背离,MJ1,0),COLORWHITE,LINETHICK2;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注