通达信量能饱和指标公式

N1:=4;N2:=8;N3:=16;N:=34;M:=6;

HH:=MAX(HIGH,REF(CLOSE,1));

LL:=MIN(LOW,REF(CLOSE,1));

AA:=SUM(CLOSE-LL,N1)/SUM(HH-LL,N1);

BB:=SUM(CLOSE-LL,N2)/SUM(HH-LL,N2);

CC:=SUM(CLOSE-LL,N3)/SUM(HH-LL,N3);

B:(AA/N1+BB/N2+CC/N3)*N1*N2*N3/(N1*N2+N2*N3+N1*N3)*100,COLORRED,LINETHICK2;

S:EMA(B,M),COLORCYAN,LINETHICK2;

{DRAWGBKLAST(V>1,STRIP(RGB(0,0,0),RGB(90,90,90),0));}

{股票资源网-股票公式网站 www.91goo.com}

SAT:=(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N));

饱和度:IF(SAT>1,1,SAT)*100;

量能≤5:STICKLINE(饱和度<=5,5,饱和度+20,4,0),COLORWHITE;

量能5~80:STICKLINE((饱和度>5 AND 饱和度< 80),5,饱和度+8,4,0),COLOR5290FF;

量能80~97:STICKLINE((饱和度>80 AND 饱和度< 97),5,饱和度,4,0),COLORRED;

量能≥97:STICKLINE(饱和度>=97,5,饱和度,4,0),COLORYELLOW;

{IF BARSTATUS=2 AND (饱和度) THEN BEGIN DRAWTEXTREL(0,100,’饱和度:’+NUMTOSTRN(饱和度,2)),LINETHICK6,COLORCCFFCC;END;

DIFF : (EMA(CLOSE,9) – EMA(CLOSE,17))*50,COLORRED;};

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注