通达信北狼指标公式

百万指标改编:=STICKLINE(C>0,20,20,50,0),COLORCCFF99;

VAR1:=MA(L,1);

VAR2:=MA(H,2);

VAR3:=MA(C,2);

VAR4:=(VAR3-LLV(VAR1,9))/(HHV(VAR2,9)-LLV(VAR1,9))*100;

VAR5:=SMA(VAR4,3,1);

【阳】:SMA(VAR5,3,1),LINETHICK2,COLOR0000FF;

K2:=BACKSET(【阳】<REF(【阳】,1),2);

IF(K2,【阳】,DRAWNULL),COLOR00A600,LINETHICK2;

IF(【阳】>REF(【阳】,1),【阳】,DRAWNULL),COLOR00FFFF,LINETHICK4,POINTDOT;

Y1:=SMA(【阳】,3,1);

VAR6:=(HHV(VAR2,9)-VAR3)/(HHV(VAR2,9)-LLV(VAR1,9))*100;

【阴】:SMA(VAR6,3,1),LINETHICK2,COLOR00FFFF;

Y2:=SMA(【阴】,3,1);

VAR7:=REF(VAR3,1);

VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;

{股票资源网-股票公式网站 www.91goo.com}

VARB:=MA(INDEXC,3)*100/MA(INDEXC,10)-100;

VARC:=MA(C,3)*100/MA(C,10)-100;

VARD:=C*100/MA(C,10)-100;

VARE:=IF(VARB>10,10,VARB);

VARF:=IF(VARE<-10,-10,VARE);

VAR10:=IF(VARC>10,10,VARC);

VAR11:=IF(VAR10<-10,-10,VAR10);

VAR12:=REF(VARB,1);

VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);

VAR14:=INDEXC;

VAR15:=REF(VAR14,1);

VAR16:=100*(VAR14-VAR15)/VAR14;

VAR17:=MA(VAR13,3);

VAR18:=MA(VAR16,3);

VAR19:=(3*C+VAR1+O+H)/6;

VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;

VAR1B:=MA(VAR1A,12);

VAR1C:=EMA(VAR1A,5);

VAR1D:=ABS(VAR1A-VAR1B);

VAR1E:=REF(VAR3,1)*0.015;

VAR1F:=REF(INDEXC,1);

VAR26:=MA(C,26);

VAR27:=VAR26+2*STD(VAR3,26);

VAR28:=VAR26-2*STD(VAR3,26);

VAR29:=VAR26+2*STD(REF(VAR3,1),26);

VAR2A:=VAR26-2*STD(REF(VAR3,1),26);

D1:=EMA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5);

D2:=REF(D1,1);

STICKLINE(D1>=REF(D1,1),D1,D2,2.5,0),COLOR00AAFF;

STICKLINE(D1>=REF(D1,1),D1,D2,1.5,0),COLOR99AAFF;

{STICKLINE(D1>=REF(D1,1),D1,D2,1,0),COLOR99DD00;}

【强弱】:SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100,COLORFFFFCC;

DRAWTEXT(ISLASTBAR=1 AND CROSS(【强弱】,Y2),80,’短期吃货!’),COLORFFFFCC;

DRAWTEXT(ISLASTBAR=1 AND CROSS(Y1,【强弱】),80,’短期出货!’),COLOR00FF00;

DRAWTEXT(ISLASTBAR=1 AND VAR17>VAR18,60,’个股强于大盘!’),COLORFF66FF;

DRAWTEXT(ISLASTBAR=1 AND VAR12>VARF,50,’大盘处在下降通道’),COLORCCFF99;

DRAWTEXT(ISLASTBAR=1 AND VAR18>=VAR17,60,’个股弱于大盘!’),COLORFFFF00;

DRAWTEXT(ISLASTBAR=1 AND VAR1A>VAR1B AND VAR1D>VAR1E AND NOT(CROSS(75,VAR8)),40,’ 持股待涨!’),COLOR6699FF;

DRAWTEXT(ISLASTBAR=1 AND VAR1A<VAR1E AND NOT(CROSS(【强弱】,20)),40,’下调减持!’),COLORFF9900;

DRAWTEXT(ISLASTBAR=1 AND VAR1D<=VAR1E,40,’盘整阶段!’),COLORFF9900;

DRAWTEXT(ISLASTBAR=1 AND (INDEXC-VAR1F)/VAR1F>0.035,40,’出现井喷行情!’),COLORFF00FF;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注