通达信四方力道+利多方舟K线主图指标公式

M5:MA(CLOSE,5),COLORWHITE;

M10:MA(CLOSE,10),COLORYELLOW;

M20:MA(CLOSE,20),COLORRED;

M60:MA(CLOSE,60),COLORGREEN;

{四方力道}

V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);

HY1:=REF(EMA(V1,3),1);

实时线:MA(CLOSE,1),COLOR006400;

神秘线:HY1,COLOR400080;

DRAWTEXT(CROSS(CLOSE,HY1),LOW,’买点’),LINETHICK2,COLORYELLOW;

DRAWTEXT(CROSS(HY1,CLOSE),HIGH*1.08,’卖点’),LINETHICK3,COLORWHITE;

APP:=(VOL / (((HIGH – LOW) * 2) – ABS((CLOSE – OPEN))));

ZL:=IF((CLOSE > OPEN),(APP * (HIGH – LOW)),IF((CLOSE < OPEN),(APP * ((HIGH – OPEN) + (CLOSE – LOW))),(VOL / 2)));

SF:=IF((CLOSE > OPEN),(0 – (APP * ((HIGH – CLOSE) + (OPEN – LOW)))),IF((CLOSE < OPEN),(0 – (APP * (HIGH – LOW))),(0 – (VOL / 2))));

库存能量:=MA((ZL + SF),2);

库存平均:=MA((ZL + SF),5);

DRAWTEXT(CROSS(库存能量,库存平均),L*0.97,”),COLORFF00FF,LINETHICK4;

{操盘手}

VAR3:=LLV(HIGH,240);

VAR4:=100*(CLOSE-VAR3)/VAR3;

VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;

VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

VAR7:=0;

VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);

VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

{股票资源网-股票公式网站 www.91goo.com}

VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);

买1:=VAR10;

买2:=(VAR11+VAR13+VAR15+VAR17);

卖1:=(VAR12+VAR14+VAR16+VAR18);

B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;

DRAWTEXT(FILTER(VAR10 OR VAR11,5),LOW,’买入’),COLORRED;

S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;

DRAWTEXT(FILTER(VAR12 OR VAR14,3),HIGH,’卖出’),COLORGREEN;

{利多方舟}

VAR100:=(100 – ((90 * (HHV(HIGH,20) – CLOSE)) / (HHV(HIGH,20) – LLV(LOW,20))));

VAR200:=(100 – ((90 * (HHV(HIGH,20) – CLOSE)) / (HHV(HIGH,20) – LLV(LOW,20))));

VAR300:=(100 – MA(((100 * (HHV(HIGH,5) – CLOSE)) / (HHV(HIGH,5) – LLV(LOW,5))),34));

F:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;

X1:=(C+L+H)/3;

X2:=EMA(X1,6);

X3:=EMA(X2,5);

GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5));

GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);

GR4:=H=HHV(H,GR1);

GR5:="MACD.MACD"(9,17,8)<REF("MACD.MACD"(9,17,8),1);

LC := REF(CLOSE,1);

RSI6:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

BIAS5:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

换手:=100*V/CAPITAL;

EMA8:=EMA(C,8);

AA1:=AMOUNT/VOL;

BB1:=L<AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD1:=L<MA(C,6)*0.921;

EE1:=VOL<MA(V,5)*1.5;

FF1:=BB1 AND CC1 AND DD1 AND EE1;

DRAWTEXT(FF1,L*0.99,’买点’),COLOR00FF00;

STICKLINE(FF1,H,L,0.3,0),COLOR00FF00;

A2:=(C-REF(C,1))/REF(C,1)*100<1.02;

A3:=H>MA(C,5)*1.12;

AA:= A2 AND A3;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注