通达信六大金叉指标公式

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

DRAWICON(DIFF>DEA,1,1);

DRAWICON(DIFF<DEA,1,2);

MCDA金叉:DIFF>DEA;

RSV:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

DRAWICON(K>D,2,1);

DRAWICON(K<D,2,2);

KDJ金叉:K>D;

LC:=REF(CLOSE,1);

RSI1:=(SMA(MAX(CLOSE-LC,0),9,1))/(SMA(ABS(CLOSE-LC),9,1))*100;

RSI2:=(SMA(MAX(CLOSE-LC,0),26,1))/(SMA(ABS(CLOSE-LC),26,1))*100;

DRAWICON(RSI1>RSI2,3,1);

DRAWICON(RSI1<RSI2,3,2);

RSI金叉:RSI1>RSI2;

LWR1:=SMA(RSV,3,1);

LWR2:=SMA(LWR1,3,1);

DRAWICON(LWR1>LWR2,4,1);

DRAWICON(LWR1<LWR2,4,2);

LWR金叉:LWR1>LWR2;

{股票资源网-股票公式网站 www.91goo.com}

BBI:=(MA(CLOSE,3)+MA(CLOSE,9)+MA(CLOSE,12)+MA(CLOSE,26))/4;

DRAWICON(CLOSE>BBI,5,1);

DRAWICON(CLOSE<BBI,5,2);

BBI金叉:CLOSE>BBI;

MTM:=CLOSE-REF(CLOSE,1);

MMS:=100*EMA(EMA(MTM,9),9)/EMA(EMA(ABS(MTM),9),3);

MMM:=100*EMA(EMA(MTM,26),12)/EMA(EMA(ABS(MTM),26),12);

DRAWICON(MMS>MMM,6,1);

DRAWICON(MMS<MMM,6,2);

MMS金叉:MMS>MMM;

MCDA金叉 AND KDJ金叉 AND RSI金叉 AND LWR金叉 AND BBI金叉 AND MMS金叉,COLORRED,LINETHICK2;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注