通达信统一化主图指标公式

N:=5;M:=13;

市盈率:C/FINANCE(33),NODRAW;

每股收益:FINANCE(33),NODRAW;

公积金:FINANCE(18),NODRAW;

流通股本:FINANCE(7)/100000000,NODRAW;

总股本:FINANCE(1)/100000000,NODRAW;

换手率%:VOL/CAPITAL*100,COLORRED,

{股票资源网-股票公式网站 www.91goo.com}

NODRAW;

MA5:MA(C,N),COLORWHITE;

MA18:=MA(CLOSE,18);

MA13:MA(C,M),COLORGREEN,LINETHICK2;

VAR1:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);

VAR2:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);

VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);

A:=(3*C+L+O+H)/6;

VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+

14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)

+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;

MTM:=C-REF(C,1);

DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

CB:=EMA(VAR4,13);

{红}

STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),COLOR0000FF;

STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;

{蓝}

STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3,0),COLORFF9900;

STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.5,0),COLORFFCC00;

{粉}

STICKLINE(VAR1,C,(O+C)/2,3,0),COLORFF11FF;

STICKLINE(VAR1,C,(O+C)/2,0.5,0),COLORFFDDFF;

{灰}

STICKLINE(VAR2,C,(O+C)/2,3,0),COLOR999999;

STICKLINE(VAR2,C,(O+C)/2,0.5,0),COLORFFBBFF;

{绿}

STICKLINE(VAR3,O,(O+C)/2,3,0),COLOR00BB00;

STICKLINE(VAR3,O,(O+C)/2,0.5,0),COLOR00FF00;

卖:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);

DRAWTEXT(FILTER(卖=1,1),HIGH*1.02,’卖’),COLORGREEN;

买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));

DRAWTEXT(FILTER(买=1,5),LOW-0.03,’买’),COLORRED;

加仓:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;

DRAWTEXT(FILTER((CROSS(加仓,0) OR CROSS(CLOSE,CB)) AND 买=1,3),LOW-0.03,’加’),COLORWHITE;

跟:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);

DRAWTEXT(跟,LOW*0.96,’跟’),COLORCC66FF;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注