通达信同舟共舞标公式

DIFF := EMA(CLOSE,12) – EMA(CLOSE,26);

DEA :=EMA(DIFF,9);

MACD :=1000* (2*(DIFF-DEA))/EMA(C,30);

VARA:=EMA(REF(CLOSE,1),4);

色彩峰:=(SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100);

准备:=色彩峰<3.5,COLORDBDBDB;

出航:=FILTER(MACD<0 AND MACD>REF(MACD,1) AND 色彩峰<20,5), COLORBROWN;

飞燕:=CROSS(色彩峰,90),COLOR00FF00;

回归:=CROSS(色彩峰,90),COLORDBDBDB;

STICKLINE(色彩峰,0,120,10,0),COLOR8BA400;

STICKLINE(色彩峰,0,90,10,0),COLOR8BA433;

STICKLINE(色彩峰,0,75,10,0),COLOR8BA466;

STICKLINE(色彩峰,0,60,10,0),COLOR8BA488;

STICKLINE(色彩峰,0,50,10,0),COLOR8BA4AA;

STICKLINE(色彩峰,0,40,10,0),COLOR8BA4BB;

STICKLINE(色彩峰,0,35,10,0),COLOR8BA4CC;

STICKLINE(色彩峰,0,25,10,0),COLOR8BA4EE;

STICKLINE(色彩峰,0,15,10,0),COLOR8BA5FF;

STICKLINE(色彩峰,0,-50,10,0),COLOR8BA433;

STICKLINE(色彩峰,0,-30,10,0),COLOR8BA444;

STICKLINE(色彩峰,0,-10,10,0),COLOR8BA455;

STICKLINE(色彩峰,0,-5,10,0),COLOR8BA466;

STICKLINE(色彩峰>0,0,色彩峰,10,0),COLOR66FF00;

STICKLINE(色彩峰>0,0,色彩峰*0.9,10,0),COLOR66EE00;

STICKLINE(色彩峰>0,0,色彩峰*0.8,10,0),COLOR66CC00;

STICKLINE(色彩峰>0,0,色彩峰*0.7,10,0),COLOR66AA00;

STICKLINE(色彩峰>0,0,色彩峰*0.6,10,0),COLOR668800;

STICKLINE(色彩峰>0,0,色彩峰*0.5,10,0),COLOR666600;

STICKLINE(色彩峰>0,0,色彩峰*0.4,10,0),COLOR664400;

STICKLINE(色彩峰>0,0,色彩峰*0.3,10,0),COLOR662200;

STICKLINE(色彩峰,0,-色彩峰*0.2,10,0),COLOR324D00;

RSV:= (CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;

FASTK:=SMA(RSV,3,1);

龙K:=SMA(FASTK,2,1);

龙D:=SMA(龙K,5,1);

狗:=LLV(LOW,10);

年:=HHV(H,25);

到来:=EMA((C-狗)/(年-狗)*4,4);

恭喜:STICKLINE(CROSS(到来,0.3),-50,-30,3,0), COLOR00AAFF,LINETHICK1;

STICKLINE(CROSS(到来,0.3),-40,-30,3,0),COLORRED,LINETHICK1;

发财:STICKLINE(CROSS(3.5,到来),100,120,2,0), COLORRED,LINETHICK2;

STICKLINE(CROSS(3.5,到来),110,120,2,0),COLORYELLOW,LINETHICK2;

{股票资源网-股票公式网站 www.91goo.com}

龙行凤影:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)

-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)

-LLV(LOW,27))*100,5,1),3,1),LINETHICK0;

双起双飞:IF(龙行凤影<=10,-30,-50),COLOR0000FF,LINETHICK2;

DD:=IF(MACD>=0,MACD,DRAWNULL);

LL:=IF(MACD<0,-MACD,DRAWNULL);

STICKLINE(DD,0,DD,3.8,0),COLOREAEAEA;

STICKLINE(DD AND DD>REF(DD,1),DD*0.1,DD*0.9,2.5.0,0),COLOR666666;

STICKLINE(DD AND DD>=15 AND DD>REF(DD,1),DD*0.7,DD*0.7,2.5,1),COLOREAEAEA;

STICKLINE(DD AND DD>=15 AND DD>REF(DD,1),DD*0.5,DD*0.5,2.5,1),COLOREAEAEA;

STICKLINE(DD AND DD>=15 AND DD>REF(DD,1),DD*0.3,DD*0.3,2.5,1),COLOREAEAEA;

STICKLINE(DD AND DD<REF(DD,1),DD*0.1,DD*0.9,2.8,1),COLOR57E000;

STICKLINE(DD AND DD>=15 AND DD<REF(DD,1),DD*0.7,DD*0.7,2.5,1),COLOR666666;

STICKLINE(DD AND DD>=15 AND DD<REF(DD,1),DD*0.5,DD*0.5,2.5,1),COLOR666666;

STICKLINE(DD AND DD>=15 AND DD<REF(DD,1),DD*0.3,DD*0.3,2.5,1),COLOR666666;

STICKLINE(LL AND LL<REF(LL,1),0,LL,0,0),COLOREAEAEA;

STICKLINE(龙K>=龙D,龙D,龙K,3,0),COLOR000085;

STICKLINE(龙K<龙D,龙D,龙K,3,0),COLOR324800;

DRAWTEXT(准备,-10,’ャ’),COLORDBDBDB;

DRAWTEXT(准备,-10,’︼’),COLOR688EC1;

DRAWTEXT(CROSS( 0,MACD)AND 色彩峰>75,110,’☆’),COLORFFFFFF;

DRAWTEXT(飞燕,70,’ヲ’),COLORDBDBDB;

DRAWTEXT(出航,-10,’Ψ’), COLORBROWN;

红红的天:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)

-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)

-LLV(LOW,27))*100,5,1),3,1);

IF(CROSS(红红的天,2),70,-50),COLOR0000FF;

有心就有:IF(CROSS(红红的天,2),70,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF77FF;

好运!:IF(CROSS(红红的天,2),70,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;

L1:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*200-60;

凤K:SMA(L1,3,1),COLORAACCAA;

凤D:SMA(凤K,3,1),COLORAACCAA;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注