通达信自用DDX成交量指标公式

虚拟量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虚拟量,0,0.3,0.5),COLORRED;

VOLUME:VOL,VOLSTICK;

VAR1:=VOL/((H-L)*2-ABS(C-O));

主买:=IF(C>O,VAR1*(H-L),IF(C<O,VAR1*((H-O)+(C-L)),VOL/2)),COLORRED,NODRAW;

主卖:=IF(C>O,0-VAR1*((H-C)+(O-L)),IF(C<O,0-VAR1*(H-L),0+V/2)),COLOR00FF00,NODRAW;

【差】:(主买+主卖),NODRAW,COLOR0000FF;

K:=IF(【差】>0,【差】,-【差】);

STICKLINE(【差】>0,0,K,2.5,0),COLOR000088;

STICKLINE(【差】>0,0,K,1.8,0),COLOR0000AA;

STICKLINE(【差】>0,0,K,1.2,0),COLOR0000CC;

STICKLINE(【差】>0,0,K,0.4,0),COLOR0000EE;

STICKLINE(【差】<0,0,K,2.5,0),COLOR008800;

STICKLINE(【差】<0,0,K,1.8,0),COLOR00AA00;

STICKLINE(【差】<0,0,K,1.2,0),COLOR00CC00;

STICKLINE(【差】<0,0,K,0.4,0),COLOR00EE00;

AA1:=VOL<REF(LLV(VOL,20),1);

AA2:=VOL<REF(LLV(VOL,60),1);

AA3:=VOL<REF(LLV(VOL,100),1);

STICKLINE(AA1,0,V,1,1),COLORBLUE;

STICKLINE(AA2,0,V,0.6,1),COLORMAGENTA;

STICKLINE(AA3,0,V,0.3,1)COLORWHITE;

DDX:=主买+主卖;

DX:=MA(DDX,5)*5;

DDX1:SMA(DX,3,1),COLORRED,LINETHICK1;

DDX2:SMA(DDX1,3,1),COLORYELLOW,LINETHICK1;

DDX3:EMA(DDX2,5),COLORF0F000,LINETHICK1;

X1:=(3*C+L+H+O)/6;

F:=(EMA(CLOSE,5)-EMA(CLOSE,21))*4;

VAR10:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);

VAR20:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);

VAR30:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);

{股票资源网-股票公式网站 www.91goo.com}

VAR40:=(20*X1+19*REF(X1,1)+18*REF(X1,2)+17*REF(X1,3)+16*REF(X1,4)+15*REF(X1,5)+

14*REF(X1,6)+13*REF(X1,7)+12*REF(X1,8)+11*REF(X1,9)+10*REF(X1,10)+9*REF(X1,11)+8*REF(X1,12)

+7*REF(X1,13)+6*REF(X1,14)+5*REF(X1,15)+4*REF(X1,16)+3*REF(X1,17)+2*REF(X1,18)+REF(X1,20))/210;

MTM:=C-REF(C,1);

DX1:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

CB:=EMA(VAR40,13);

卖1:=HHV(DX1,2)=HHV(DX1,7) AND COUNT(DX1>50,2) AND CROSS(MA(DX1,2),DX1);

DRAWTEXT(FILTER(卖1=1,1),VOLUME*-0.1,’卖’),COLOR00C800;

买1:=LLV(DX1,2)=LLV(DX1,7) AND COUNT(DX1<0,2) AND CROSS(DX1,MA(DX1,2));

DRAWTEXT(FILTER(DDX1>=DDX2 AND 买1=1,5),VOLUME*-0.1,’买’),COLORYELLOW;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注