通达信闪电之王指标公式

VAR1:="DMI.PDI"(12,6);

VAR2:="DMI.MDI"(12,6);

VAR3:=VAR1>65 AND VAR1>REF(VAR1,1);

VAR4:=LLV(VAR1,0);

VAR5:=BARSLAST(VAR4=VAR1);

VAR6:=(0-REF(VAR2,4))/(VAR4-REF(VAR2,VAR5))>2;

VAR7:=VAR1>REF(VAR1,1);

VAR8:=VOL>2*MA(VOL,30);

VAR9:="DMI.ADX"(12,6);

VARA:="DMI.ADXR"(12,6);

VARB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;

VARC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);

VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));

VARE:=0-"MACD.DIF"(7,21,3);

VARF:=TROUGHBARS(3,15,1)<4;

{股票资源网-股票公式网站 www.gpzyw.net}

VAR10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);

VAR11:=IF(VARF=1,50,0);

VAR12:=CROSS(VAR2,VAR1) AND CROSS(VARA,VAR9);

VAR13:=CROSS(VAR2,VAR1) AND CROSS(VAR9,VARA);

VAR14:=VARB AND VARC AND VARD AND VAR10 AND VAR6 AND VAR7 AND VAR8*50;

VAR15:=BARSLAST(CROSS(VAR2,VAR1)=1);

VAR16:=BARSLAST(CROSS(VAR1,VAR2)=1);

VAR17:=HHV(VAR1,VAR16);

VAR18:=BARSLAST(VAR1=VAR17);

多空:EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;

0,COLORRED;

STICKLINE(FILTER(VARF=1,5) AND 多空<-10,50,0,30,0),COLORRED;

STICKLINE(FILTER(VARF=1,5),50,0,10,0),COLORRED;

VAR19:=VAR3 OR VAR12 OR VAR13*100;

VAR1A:=VAR13*100;

DRAWICON(FILTER(VARF=1,3),50,1);

DRAWTEXT(FILTER(VARF=1,3),25,’雷电交加’),COLORYELLOW;

STICKLINE(多空<-10,0,多空,1,0),COLORYELLOW;

STICKLINE(多空>10,0,多空,1,0),COLORYELLOW;

 

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注